Specifying the desired JVM version

The Minimum JVM version setting under Java Runtime lets you specify the minimum JVM version that your application requires to run properly. It puts a floor on the system requirement and alerts the user if the installed Java runtime does not meet that requirement.

Starting from V5.2.7, you can refine the rules further and specify multiple constraints if necessary.

The new rules supported are:

The five rule formats signify "equals", "greater", "greater-or-equals", "less-than", "less-than-or-equals" comparison respectively. So "=1.6.0" essentially means the application will only work with a V1.6.0 JVM. Each successive component of the version string is optional, and will default to 0 if missing, but should not be greater than 99 if present.

Multiple criteria can be specified by delimiting with semi-colons: eg. ">=1.2;<1.7". Each semi-colon signifies an "AND" operator, so the previous example means the application requires a JVM that is between V1.2 to V1.6, but will not work with a V1.7 JVM.